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Through my years of studying Photoshop, I've had the opportunity to use it many times as a
way of reducing photographic material to charts. The program has all the tools you
are likely to need, and even relatively inexperienced users can have good results. As
you work through this tutorial, | think you will find that, though there are many steps,
no one step is difficult, nor is it hard to understand.

Pick your photo

Your choice of photo is the most important decision you will make in this process.
Good choices are images with strong contrast. The image should include shapes that
are easily identified even if the you look at them with your eyes slightly out of focus.
The process of converting to a chart will destroy most of the photo's detail, and you
will want there to be no doubt about what the chart depicts. For that reason, you will
want to avoid photographs that depend on detail.

For this study, I've chosen the hibiscus flower in Figure 00.This photo exhibits most
of what I've described as desirable qualities for conversion to a chart. It has excellent
contrast, detail that is relatively unimportant, a limited range of colors,and robust
shapes.

Figure 00 Original photograph to be converted to chart.

Before you begin the conversion, it will be a good idea to enhance your image as much as possible.
You will want to adjust it's color and to make sure that the color ranges available have a
range that is as wide as possible.You can, if you wish, force the colors into ranges that
would be unacceptable in any other circumstance. The conversion will tame those colors.



When the image is as good as you can make it, select Image Size from under the
Image menu.The dialog box for Image Size is shown in Figure 01
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Figure 01 Image Size dialog box with default settings

The dialog box contains all of the information that relates to this file's current dimensions and
resolution. It is here that we must change the file's dimensions so that the pixel
numbers in either direction are some multiple that will be easy to remember. Let’s
say that when we work on this chart, we would like to have the squares 25 pixels
wide and tall. As you can see, the width in pixels would not divide by 25 without a
remainder. However, that's an easy matter to fix.
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Figure 02 By turning off--unchecking--Constrain Proportions, Photoshop will allow you to resize the
image asymmetrically.

Uncheck the Constrain Proportions checkbox and then enter a new dimension in the width
data-entry field. In this case, | eliminated the extra 17 pixels.| could as easily have
added 8 more pixels to bring the number up to 1725.This is one of the few cases in
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Photoshop where not resizing proportionally is not especially harmful to the
image. If you'll compare Figure 03 with Figure 00, you'll see that there are few
visible differences.

Figure 03 The image has been asymmetrically resized and does not appear very different.

All of the fussy work is now out of the way. From now on you'll be able to concentrate on
creating your graph.

Changing the photo image into squares is accomplished by applying the Mosaic
filter. The Mosaic dialog box is seen below in Figure 04.
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Figure 04 The squares of the chart are created by using the Mosaic filter.

You'll recall that the Image Size command was used to make sure the pixel dimensions of the
photo were multiples of 25.25 is now the cell size to request of the filter. When the
filter has executed, you will see that your image has substantially changed. Notice
that even at this stage, the flower and the leaves are still easily recognizable. Using
this filter is a very good way to decide if an image is suitable. If the shapes are not
recognizable, it isn't worth your while to proceed.



Page 4

Figure 05 After the Mosaic filter is applied, the image is still recognizable.

Having destroyed nearly all of the image’s detail, the next task is to severely reduce the
number of colors. Assuming that this is an RGB file, it has the potential of having up
to nearly 17,000,000 colors. You must decide what number of colors with which you
wish to work. For knitting--possibly intarsia--you might wish to retain quite a few
colors. If you are developing these charts for cross stitch or needlepoint, you could
retain as many as you wish provided you can find yarns to match them.There are a
few other things to consider. This image contains colors that are mainly red and
green. However many colors you choose to retain, half will belong to the green
group and half to the red. If we were to isolate the flower so that the image
contained only the blossom, then all of the values could be in the red range. With
more values, there is more color differentiation and the chart will be more real.

From the Image menu, choose Model|Indexed color.
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Figure 05 To limit the number of colors, the image is converted to Indexed Color.



Page 5  The Indexed Color dialog box, shown in Figure 07, has a bewildering number of choices.When you
convert your image, make your dialog box look like this one. The one variable is how
many colors you wish to retain. If the number is more or less than the number shown, go
ahead and make the change.Immediately change the file back to RGB mode.
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Figure 07 The Indexed Color dialog box lets you enter exactly the number of colors to retain.

Figure 08, below, has now been reduced to 10 colors. | used that number because it doesn't

seem so far out of reach for intarsia knitters, especially when duplicate stitch can be
used for isolated stitches.

As you can see from the figure, this image is still recognizable. Loosing color certainly
does destroy detail, but there is no doubt that this is a flower of some kind, and that
it is surrounded by leaves and leafy shadows.

Figure 08 With Index Color, this image has been reduced to 10 colors.



The flower chart looks pretty good at this stage and could probably be used with no further Page 6
modification. However, there are some fairly simple things that you can do to make it
more usable. One possibility is to delineate the squares with a grid. We can make the
grid white where it outlines very dark squares, and black everywhere else.

From the File menu, select New.
PeiEr
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Figure 09 This 25x25 pixel file will allow us to outline the squares with a grid.

When the dialog box appears (Figure 09, above), name the new file something like the title
shown in the figure. The dimensions are the same size as the squares in the flower
image. You will also need to insure that the resolution and color mode of the new
file are the same as for the photo chart.

The new window will appear. From the Select menu, choose All. From the Edit menu,
select the Stroke command (Figure 10, below). Clock OK.
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Figure 10 The Stroke command will place a line around the edges of the new file.



Page 7 It will probably be easier to understand why we are choosing a Stroke width of one pixel after

you have applied it.I'll try to state the reasons and ask that you file the information
and come back to it laser when you have seen the grid constructed.

We need to use a line size for the grid that is not too wide or it will block too much
of the color. a half-point line will be perfect. The file is at a resolution of 300 ppi. At
that density, a one-half point line is almost exactly 2 pixels wide.You will be using
many versions of this square stacked on top of each other and next to each other. As
they fit together, each square will contribute half the width of the grid. The end result
will be a line of the desired size.

From the Image menu, choose Duplicate. Another Dialog box will appear. Type in the
name White Grid. When the new window appears, hold down the Command key
(Mac) or the Control key (Windows) and type i.The line around the edge of the new
window will change to white by using this Invert command, as shown in Figure 11.

*| Black Grid

S0

) BOOPS (L O 7 White Grid @ BOPG (... =]

g |4 IC

Figure 11 These two windows will provide both of the grids needed for the chart.

We'll work on the light grid first. Make the White Grid the active window. Choose All from the

Select menu. From the Edit menu, choose Define Pattern (Figure 12). A pattern, in
Photoshop terms, is any rectangular shape that has been designated. When patterns
are used as fills, Photoshop tiles the patterns throughout the selection area. Patterns
are very powerful and quite underused.
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Figure 12 To make the White Grid file behave as a grid, you define it as a pattern.



Before you put your new pattern to use, you need to do a bit of preparation. First, if you Page 8
cannot see it, look under the Window menu and choose Show Layers.Your image
should show on the Layers palette as the Background layer. Just to the right of the
small Trash Can icon at the bottom of the pallets is the New Layer icon. Click it to
create a new layer above the original.

Type W to select the Magic Wand tool. If you do not have the Options palette open,
use the Show command under the Windows menu. Make the settings on your
palette agree with those in Figure 13.
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[Juse All Layers [ contiguous

Figure 13 Your Magic Wand settings will be most useful if these settings are used.

On the Layers palette, click on the Background Layer to select it. Click with your
Magic Wand anywhere on the image where you see an area of the darkest color
present. Immediately, all of dark colored areas, everywhere in the image, are selected.
Return to the Layers palette and click on Layer 1 to select it. Hold down the Shift key
and type Delete or Backspace.This is the command used to summon the dialog box
for filling selections (Figure 14).
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Figure 14 The Use option allows you to fill with a pattern if one has been defined.

The Use popup menu allows you to choose from a couple of colors for the fill. However, it also
allows you to fill with a pattern if one has been defined.You have a pattern defined.
Click OK and you'll see your white square magically spread out and fit itself to the
area of the darkest squares (Figure 15, top of opposite page). Photoshop calculates
the placement of patterns beginning in the upper left-hand corner of the window.
Since your pattern tile is 25 x 25,and since the squares of the chart are the same size,
your patterns will always fit this way.

Click again on the Background layer. With the Magic Wand, click on the image in a
place occupied by the next lighter color--ie, the second darkest. Again select Layer 1.
Type Shift+Delete or Shift+Backspace and Click OK. Again the pattern spreads itself
into the selected area (Figure 17, opposite page). Do not deselect just yet.



Figure 15 Your white pattern smoothly aligns itself to the darkest squares.

Figure 16 The white pattern now delineates the two darkest colors.




If you look closely at Figure 16, you'll see that there is some difficulty distinguishing between Page 10
the two darkest colors once the pattern has been in place.We need a way to identify
the two so that they are instantly recognized as different. Make your White Grid
window active. Choose the Marquee selection tool (type m to select it) and make a
small selection in the very center of the square as shown in Figure 17a.

Note:In this figure, white against a background of gray and white is very hard to see.
I have shaded it blue for purposes of illustration. You will use white instead of blue.
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Figure 17a, left Put a small spot in the center of the White Grid file to make a new pattern tile.
Figure 17b, right Put a small line in the center of the Black Grid file to make a new pattern tile.

Select All, Define the Pattern, and return to the flower window. The selection defining the
second darkest color is still selected. Type Shift+Delete or Shift+Backspace and click
OK.The new pattern overwrites the original. The result is as shown in Figure 18.

Figure 18 The modified white grid makes it easy to distinguish between the two darkest colors.



Page 11 Lets take a shortcut to completing the entire grid. All of the rest of the colors are light enough
that they can support a grid of black. Click on the small Eye icon on the Layers
palette to hide Layer 1.Click on the Background layer to select it. Hold down the Shift
key and click in the image on an area of the darkest color. Now click on an area of
the second darkest.You have now selected all of the dark-color area.

Return to the Layers palette. Make Layer 1 visible. Click on the Background layer,and
then click on the New Layer icon at the bottom.The new layer will be automatically
named layer 2.We are going to use Layer 2 as the layer to contain the black grid.

From the Select menu, choose Inverse.This deselects the dark colors and selects
everything else. Bring the Black Grid window to the front. Select All, Define the
Pattern, and return to the flower window. Summon the Fill dialog box, and click OK.
You see the results in Figure 19.

Figure 19 Both gri clors are now in pace.

As you can see from this figure, the vivid red and the next lighter color are difficult to
distinguish. It is a simple matter to bring the Black Grid window to the front and to
use the line tool to make a small mark in the center (Figure 17b).This new iteration
of the Black Grid pattern tile, when applied to the vivid red color, produces the effect
shown in Figure 20 (top of the following page).

You can, if you wish, assign small symbols to every color. Coming up with symbols is
simply a matter of imagination. For example, take the just-used mark and flip it along
a vertical axis to make a slanted line in the other direction. Or take one line in each
direction and combine them into an X.If you leave your file in layers, you can come
back to it and modify it as often as you wish to do so.
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Figure 20 The marked variation of the black grid helps distinguish between two close reds.

There is a small house-cleaning task that needs attention. It is shown in figure 21.Where the
white grid and the black grid meet, the effect is untidy looking—and easy to fix!

Figure 21 The boundary where white lines meet dark lines looks messy and needs to be fixed.




Page 13 Hide Layers 1 & 2. Use the Magic Wand to select both of the dark colors (hold down the Shift
key and click on both). Select Inverse from the Select menu. Make both Layers visible.
Click on Layer 1 to select it.

Type D and then X. D makes your Foreground/Background colors black and white. X
reverses the arrangement. You need to have your Foreground color as white for the
next operation. From the Edit menu, choose Stroke. When the dialog box appears,
make your stroke one pixel and choose the Outside option. Click OK..Photoshop will
draw a one-pixel white stroke all around the outside of the white-grid area.The result
is shown in Figure 22. Compare this to the previous figure to see how successful this
clean-up maneuver is.

Figure 22 A white stroke around the entire white-grid area tidies the grid.

It is likely that the grid you have constructed will be too small for you to use easily. Please
select Image Size from the Image menu. As you can see in Figure 23 (following
page), the resolution is 300 ppi. Given that our squares are 25 pixels on a side, that
makes each square 25/300 or 1/12 inches on a side. If you change this dialog box to
the way it is shown in Figure 24, you can make the squares increase in size.You do
that by taking away Photoshop's resampling capability. When you have done that,
Photoshop is forbidden to manufacture new pixel values. All it can do, when you
specify a smaller number for resolution, is to make the pixels larger. By changing to
200 ppi, you have changed the square size to 25/200 or 1/8 inches on a side.The
final chart, shown on page 15, has been turned on its side so that you can see how
clear the results can be.

| hope you have enjoyed this examination of using Photoshop to make charts from

digital photographs.This file is offered as a gesture of thanks to the members of
KnitU who have enriched my life beyond describing.

David Xenakis

May 2,2000



Image Size Page 14
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Figure 23 This resolution, with 25-pixel squares, makes each square 1/12” on a side.
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Figure 24 Using this setting changes the squares to 1/8” on a side.



Figure 25 The final chart, turn on its side so that the entire image can be seen.




Although this set of instructions was written with Adobe Photoshop in mind, there
are other software possibilities that you can consider. They are listed here:

Photoshop Elements from Adobe Systems, Inc. (Windows)
Photoshop Elements from Adobe Systems, Inc. (Mac)

Photoshop CS from Adobe Systems, Inc. (Windows)
Photoshop CS from Adobe Systems, Inc. (Mac)

Adobe lllustrator from Adobe Systems, Inc. (Windows)
Adobe lllustrator from Adobe Systems, Inc. (Mac)

Stitch Painter from Cochenille Design Studio

Adobe lllustrator
for Fashion Design
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by Susan Lazear
Professor of Fashion
Mesa College, San Diego, California
© 2007, All Rights Reserved



http://www.adobe.com/products/photoshopelwin/
http://www.adobe.com/products/photoshopelmac/
http://www.adobe.com/products/photoshop/photoshop/
http://www.adobe.com/products/illustrator/
http://www.cochenille.com/

